Свежие комментарии
Посещение сайта
Благодарность: Школа StartUp.
)

Работа в программе MS Excel

 Работа в программе MS Excel

Редактирование

Перемещение по таблице:

  • с помощью клавиш управления курсором;
  • с помощью линейки прокрутки.

 Ввод данных

Типы данных:

  • текст
  • число
  • дата (20.03.2013)
  • время (13:30:55  часы : минуты : секунды )
  • формула.

Текст и числа, представляют собой постоянные величины. Являются исходными значениями в формулах.

Формула содержит вычисляемое значение. Результат вычисления формулы может меняться при изменении исходных значений.

Скачать цикл лабораторных работ по MS Excel

Текст в MS Excel

Текстом в Excel является любая последовательность, состоящая из цифр, пробелов, и нецифровых символов.    Например, 987$$79, 100 рублей. При использовании в формулах текстовое значение берется в апострофы (Пример «Зима»);

Форматы числовых данных  

Числовой формат в  Excel бывает:

  • непосредственно число  (3,56 -4,6 — разделитель между целой и дробной частью -по умолчанию в Excel — ЗАПЯТАЯ );
  • процентный (%)
  • денежный ( р. или др. валюта)
  • дробный  (1/4)
  • экспоненциальный (Е е )

Число в Excel может состоять только из следующих символов: 0 1 2 3 4 5 6 7 8 9 + — ( ) , / % . Е е Все другие комбинации, состоящие из цифр и нецифровых символов, интерпретируются как текст.

Если перед числом стоит знак плюс, он игнорируется. Перед отрицательным числом необходимо ввести знак минус или заключить его в круглые скобки. В качестве десятичного разделителя используют запятую.

По умолчанию используется Общий формат. В этом формате для вывода чисел используется целочисленный формат (1964), десятичный дробный (19,64) и экспоненциальный (1,64Е+03), если числа длиннее ширины ячейки. Числа выровнены вправо.

Формат →  Ячейки →  Число

Изменение числового формата не влияет на само значение. Иногда, чтобы увидеть настоящее значение, приходится изменить формат ячейки на Общий.

Формула в MS Excel  

Формулой в Excel называется выражение, начинающееся со знака равенства и состоящее из последовательности значений, ссылок на ячейки, имен, функций или операторов, которые порождают новую величину.

Формулой в Excel называется введенная в ячейку последовательность символов, начинающаяся со знака равенства. Иначе она будет считаться текстом.

Содержимое формул

операторы

ссылки на ячейки

значения

функции

арифметические относительные текстовые
текстовые абсолютные числовые
сравнения смешанные
адресные

 

Операторы

Операторы – инструкции, применяемые для решения определенных задач.

Операторы в формулах применяются для обозначения действия, например, сложения, вычитания и т.д.

Арифметические операторы используются для обозначения основных математических операций над числами. Результатом выполнения арифметической операции всегда является число.

Текстовый оператор (знак присоединения текстов) используется для обозначения операции, позволяющей использовать текст совместно с формулой в одной ячейке или объединять тексты из разных ячеек.

Операторы сравнения используются для обозначения операций сравнения двух значений. Результатом выполнения операции сравнения является логическое значение ИСТИНА или ЛОЖЬ.

Адресные операторы используются для задания диапазона.

Оператор

Значение

Пример

Тип

данных

Арифметические операторы
+ (знак плюс) Сложение =А1+В2

числа

– (знак минус) Вычитание =А1–В2
или отрицание (унарный минус – инверсия, если это знак перед единственным операндом) =-В2
/ (косая черта) Деление =А1/В2
* (звездочка) Умножение =А1*В2
% (знак процента) Процент (преобразование в проценты) =20%
^ (крышка) возведение в степень =5^3 (5 в степени 3)
Операторы сравнения
= Равно =ЕСЛИ(А1=В2;»Да»;»Нет»)

числа, текст

> больше =ЕСЛИ(А1>В2;А1;В2)
< Меньше =ЕСЛИ(А1<В2;В2;А1)
>= больше или равно =ЕСЛИ(А1>=В2;А1;В2)
<= меньше или равно =ЕСЛИ(А1<=В2;В2;А1)
<> не равно =ЕСЛИ(А1<>В2;»не равны»)
Текстовый оператор
& (амперсанд)знак присоединения текстов объединение последовательностей символов в одну последовательность символов =»Значение ячейки В2 равняется: «&В2

текст

Адресные операторы
: (диапазон) ссылка на все ячейки между границами диапазона включительно =СУММ(А1:В2)

числа, текст,

формула

, (объединение, перечисление) ссылка на объединение ячеек диапазонов =СУММ(А1:В2,С3,D4,Е5)
пробел (пересечение) ссылка на общие ячейки диапазонов =СУММ(А1:В2 С3 D4:Е5)

 

Ссылки (способы адресации ячеек)

В формулах используются не значения исходных данных, а адреса ячеек, в которых эти данные содержатся.

Формула задает связь ячеек, в которых находятся исходные данные.

Адрес: буквенная часть, цифровая часть.

Ссылки представляют собой включаемые в формулу адреса ячеек или диапазонов ячеек.

Ссылки в формулах задаются в виде адреса ячейки или диапазона ячеек.

1) Относительная (изменяемая) ссылка

Относительная ссылка в формуле используется для указания адреса ячейки, вычисляемого в относительной системе координат с началом в текущей ячейке. Относительные ссылки имеют следующий вид (примеры записи): А1, В3 и т.д.

Относительные ссылки обновляются относительно смещения формулы.

Относительные ссылки наиболее распространены и используются по умолчанию.

2) Абсолютная (неизменяемая) ссылка

Абсолютная ссылка в формуле используется для указания адреса ячейки, вычисляемого в абсолютной системе координат и не зависящего от текущей ячейки.

Для указания абсолютного адреса при записи формулы используется знак $ ($ — знак «абсолютности»).

Если в формуле в качестве ссылки использовано имя ячейки, то это соответствует действию абсолютной ссылки.

Разновидностью абсолютной адресации является присвоение имени ячейке или диапазону ячеек (Вставка  Имя  Определить или Ctrl+F3).

Присвоив ячейке имя, можно будет обращаться к ней в любой момент и из любой точки таблицы, даже если она неоднократно меняла свое местоположение. В поле имени в строке формул вместо адреса будет написано имя (слово). Даже находясь на другом рабочем листе, можно выполнять любые операции с поименованной ячейкой, не задавая, с какого листа ее брать.

Имена ячеек в пределах одной рабочей книги не должны повторяться. Имена могут состоять из букв (в т.ч. русских), цифр, точек и символов подчеркивания. Пробелы не допускаются. Прописные и строчные буквы воспринимаются одинаково.

С помощью окна имен можно быстро перейти к нужной ячейке: если щелкнуть по стрелочке, то появится список всех поименованных ячеек рабочей книги.

Способ ссылки не влияет на результат вычисления по формуле.

Различие между относительными и абсолютными ссылками проявляется только при копировании формул из одной ячейки в другую.

При перемещении или копировании абсолютной ссылки абсолютные  ссылки в формулах не изменяются, а относительные автоматически обновляются в зависимости от нового положения.

Переадресация происходит при копировании формул, содержащих относительные ссылки.

При вставке или удалении ячеек, строк или столбцов ссылки на ячейки, которые используются в формулах, изменяются с учетом их нового положения. Т.о., обновление формул происходит автоматически.

3)  Смешанные ссылки

Часть ссылки (не содержащая знака $) будет обновляться при копировании, а часть ссылки (со знаком $) останется без изменения.   Напимер: = A$2      =$A2

Продолжение темы редактирования MS Excel

 

Понравилась статья, рекомендуйте Вашим друзьям!

Давайте дружить!

Оставить комментарий